何回か書いていますが、このサイトはワードプレスを利用しています。
非常に便利なので気に入っているのですが、2年ぐらい使っている間に環境も徐々に変化してきました。

PHPというプログラム言語があるのですが、それが最初はバージョン5.×を使っていたのが最近では7.×になっていました。
ワードプレス自体は新しい環境に自動的に更新してくれているのですが、契約しているサーバー側で設定もしないといけないのを放置しておりました。古いとダメという訳でも無いのですが、徐々に古い環境はサポートされなくなっていきますので順次更新していく事が望ましいとは思います。

現在は何とか無事に最新の環境にしましたが、途中で非常に焦るハプニングにも遭遇しました。

バージョンが上がる際にセキュリティーの関係でサーバーのパスワードも再設定しないといけなかったようなのですが、それを見逃してしまい何もしないでバージョンを上げるとサーバー接続エラーという接続出来ない状態になってしまいました。
今から思うとパスワードが正しくないので、サーバーに接続できないのは当たり前なのですが急にエラーになると本当に焦りますね。

まずい・・・と、最悪全て設定して作り直し・・・かと思うぐらいに焦りました。
作り直しだとしても、毎日のようにバックアップは取っていますので復旧で大きな問題にはならないとは思うんですが、焦りました、本当に。

結局はマニュアルに書いている通りに設定すると問題なく復旧してますので、結局は不注意だったという事ですけどね。